Performance degradation
Incident Report for Vesto
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 12:13 EST
Monitoring
We have deployed a fix and are monitoring – there may be downtime in receiving 2FA emails.
Posted Nov 14, 2023 - 11:08 EST
Identified
We've identified a performance degradation in the platform and are working to deploy a fix
Posted Nov 14, 2023 - 09:10 EST
This incident affected: Vesto Web App.